WWT Shows CLICK TO: Join and Support Internet Horology Club 185™ IHC185™ Forums

• Check Out Our... •
• TWO Book Offer! •
Go
New Topic
Find-Or-Search
Notify
Tools
Reply to Post
  
Platform Escapement "Click" to Login or Register 
posted
I have a Seth Thomas carriage clock with a replacement Swiss platform escapement. When first wound the clock runs fine for a few days.Then, it starts to loose time. Adjusting the regulator makes little difference. To my eyes at least, the action of the balance wheel looks less robust after the first few days of running. Could this be due to an improper mainspring? Does any one have anay suggestions?
 
Posts: 767 | Location: Los Osos, California USA | Registered: December 12, 2002
Picture of Tom Seymour
posted
Jerry,

It does sound more like a power problem than a balance wheel problem. I have had similar track records with clocks that had an old spring that is set.

If it is a balance wheel problem.......well....I have spent many years avoiding blance wheels.........Then I joined this chapter. I am on the beginning edge of familiar with them.

Good luck with the clock. Let us know what you find.

Tom Seymour
NAWCC# 41293
IHC Executive V.P.
 
Posts: 2537 | Location: Mount Angel, Oregon in the U.S.A. | Registered: November 19, 2002
IHC Member 234
Picture of Jim Cope
posted
...agree w/Tom...classic symptoms of a 'set' spring...I'd pull the spring and note whether it expands to at least twice it's wound diameter...Jim C
 
Posts: 872 | Location: Kingsville, Ontario, Canada | Registered: April 16, 2003
posted
Thanks to Jim & Tom.

Jerry Freedman
 
Posts: 767 | Location: Los Osos, California USA | Registered: December 12, 2002
  Powered by Social Strata  
 


©2002-2021 Internet Horology Club 185™ - Lindell V. Riddle President - All Rights Reserved Worldwide

Internet Horology Club 185™ is the "Family-Friendly" place for Watch and Clock Collectors